richardlpalmer

Subscribe!
Contacting richardlpalmer
Send message Forward
Add to friends Favorites
Add to group Block user
Friday, December 09, 2011

Hughes & Kettner TubeMeister: Part II

Current mood: cheerful

Views: 82
Comments: 0
Well, shortly after posting my initial NAD blog, my wonderful Hughes & Kettner TubeMeister blew up on me. :(
 
Okay, "blew up" is a bit dramatic. I was playing along happily, looked down to see the footswitch and as I started casting my gaze back up noticed the amp start glowing -- brighter, Brighter, BRIGHTER, BRIGHTER, then silence...
 
I checked things out, unplugged, let it cool, etc. and couldn't figure out an obvious cause for it. I checked the manual and it looks like it's a fuse issue -- but that would only be caused by a dramatic problem with the tubes (as it has an auto-biasing feature).
 
Anyway, I figured I could fix it or have it repaired easily enough. But considering I'd only had it 2 or 3 weeks, decided to send it back and get it replaced.
 
I sent it off and received word that it was received, replaced and mailed back to me. Waiting for the replacement which I hope will be as awesome as the first one.
 
I'm also hoping it was a fluke thing because of it being a first-run manufacturing glitch or something like that. Because if this next one proves to be that fragile, I'm going to have to return it and not replace it. I guess that would be a good excuse to get that Mesa Mini Recto I've been eye-ballin', huh?
 
Stay tuned for Part III. :)
10:08 pm - 0 comments - 0 Kudos - Report!
Post your comment
Expand